Module not displaying server details.

beanman1
Topic Author
Posts: 3
4 months 5 days ago #4113 by beanman1
Module not displaying server details. was created by beanman1
I know this was asked about in a previous topic, but the solution was never posted.

My site: matr.nybn.org/

Recently added a Discord channel for my gaming group so we don't have to put things on hold because of this COVID-19 issue. Wanted to add this module to our site to aid in accessing the Discord Server.

When setting up the server, I have the @everyone group set to be allowed to "Read Text Channels & See Voice Channels" as well as "Connect" under voice permissions. Yet when I load the website, it only shows me the number of users online and the connect button just redirects back to my site's homepage.

Under Widget, I did activate "Enable Serve Widget" I then copied the Server ID and pasted it into the Module.

Any assistance would be appreciated.

Please Log in or Create an account to join the conversation.

Lodder
Lodder's Avatar
Posts: 1171
4 months 5 days ago #4115 by Lodder
Replied by Lodder on topic Module not displaying server details.
Hi beanman,

I can see that you have an error in the browser console coming from the Discord module.
I believe this is due to the lack of permissions.

In your Discord server settings, go to "Roles" >> "@everyone", then enable "Create Invite"

Regards,
Lodder

Please Log in or Create an account to join the conversation.

beanman1
Topic Author
Posts: 3
4 months 5 days ago #4116 by beanman1
Replied by beanman1 on topic Module not displaying server details.
Gave @everyone Create Invite permissions and still no change.

Please Log in or Create an account to join the conversation.

Lodder
Lodder's Avatar
Posts: 1171
4 months 5 days ago #4117 by Lodder
Replied by Lodder on topic Module not displaying server details.
Please also make sure you define an Invite Channel.

See screenshot: imgur.com/a/as1fn0a

Once done, it may take a couple of minutes for the Discord API data to update

Please Log in or Create an account to join the conversation.

beanman1
Topic Author
Posts: 3
4 months 4 days ago #4118 by beanman1
Replied by beanman1 on topic Module not displaying server details.
Outstanding!

So making sure the @everyone has invite permissions and the ability to read/see all channels as well as making sure an actual invite channel is set in the Server Widget page is what was needed to get the module to display the server details.

I greatly appreciate your help with this!

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum